#29 closed task (invalid)

Java OutOfMemoryError

Reported by: martinP Owned by:
Priority: major Milestone:
Component: code Version:
Keywords: Cc: martin

Description

Repreducebly gets an OutOfMemoryError after some time of operation in the bives2masymos project

14:19:12.944 [main] INFO  d.u.sems.masymos.diff.DiffJob - comparing model http://taylor.informatik.uni-rostock.de/models/localhost/biomodels/releases/MODEL3023609334.xml/2007-09-25/MODEL3023609334.xml and model http://taylor.informatik.uni-rostock.de/models/localhost/biomodels/releases/MODEL3023609334.xml/2007-09-25/MODEL3023609334.xml
14:19:12.945 [main] DEBUG d.u.sems.masymos.diff.DiffJob - Creating diff node
14:19:12.945 [main] DEBUG d.u.sems.masymos.diff.DiffJob - generating diff
Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
	at java.lang.StringCoding$StringEncoder.encode(StringCoding.java:300)
	at java.lang.StringCoding.encode(StringCoding.java:344)
	at java.lang.StringCoding.encode(StringCoding.java:387)
	at java.lang.String.getBytes(String.java:956)
	at de.binfalse.bfutils.GeneralTools.hash(GeneralTools.java:208)
	at de.binfalse.bfutils.GeneralTools.hashSha256(GeneralTools.java:250)
	at de.binfalse.bfutils.GeneralTools.hash(GeneralTools.java:185)
	at de.unirostock.sems.xmlutils.ds.TextNode.<init>(TextNode.java:94)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:240)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.TreeDocument.<init>(TreeDocument.java:93)
	at de.unirostock.sems.bives.algorithm.ModelValidator.validate(ModelValidator.java:91)
	at de.unirostock.sems.masymos.diff.DiffJob.parseSbmlDocument(DiffJob.java:176)
	at de.unirostock.sems.masymos.diff.DiffJob.generateDiff(DiffJob.java:143)
	at de.unirostock.sems.masymos.diff.DiffJob.run(DiffJob.java:89)
	at de.unirostock.sems.masymos.diff.DiffExecutor.execute(DiffExecutor.java:101)
	at de.unirostock.sems.masymos.diff.DiffExecutor.main(DiffExecutor.java:186)
14:52:57.211 [main] INFO  d.u.sems.masymos.diff.DiffJob - comparing model http://taylor.informatik.uni-rostock.de/models/localhost/biomodels/releases/MODEL1107190000.xml/2012-02-08/MODEL1107190000.xml and model http://taylor.informatik.uni-rostock.de/models/localhost/biomodels/releases/MODEL1107190000.xml/2012-05-20/MODEL1107190000.xml
14:52:57.211 [main] DEBUG d.u.sems.masymos.diff.DiffJob - Creating diff node
14:52:57.212 [main] DEBUG d.u.sems.masymos.diff.DiffJob - generating diff
Exception in thread "GC-Monitor" java.lang.OutOfMemoryError: Java heap space
	at java.util.Arrays.copyOfRange(Arrays.java:2694)
	at java.lang.String.<init>(String.java:203)
	at java.lang.StringBuilder.toString(StringBuilder.java:405)
	at org.neo4j.kernel.impl.cache.MeasureDoNothing.run(MeasureDoNothing.java:84)
Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
	at sun.security.provider.SHA2.<init>(SHA2.java:78)
	at sun.reflect.GeneratedConstructorAccessor11.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
	at java.lang.Class.newInstance0(Class.java:372)
	at java.lang.Class.newInstance(Class.java:325)
	at java.security.Provider$Service.newInstance(Provider.java:1238)
	at sun.security.jca.GetInstance.getInstance(GetInstance.java:236)
	at sun.security.jca.GetInstance.getInstance(GetInstance.java:164)
	at java.security.Security.getImpl(Security.java:695)
	at java.security.MessageDigest.getInstance(MessageDigest.java:159)
	at de.binfalse.bfutils.GeneralTools.hash(GeneralTools.java:207)
	at de.binfalse.bfutils.GeneralTools.hashSha256(GeneralTools.java:250)
	at de.binfalse.bfutils.GeneralTools.hash(GeneralTools.java:185)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.calcHash(DocumentNode.java:432)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:250)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.DocumentNode.<init>(DocumentNode.java:220)
	at de.unirostock.sems.xmlutils.ds.TreeDocument.<init>(TreeDocument.java:93)
	at de.unirostock.sems.bives.algorithm.ModelValidator.validate(ModelValidator.java:91)
	at de.unirostock.sems.masymos.diff.DiffJob.parseSbmlDocument(DiffJob.java:175)
	at de.unirostock.sems.masymos.diff.DiffJob.generateDiff(DiffJob.java:142)
	at de.unirostock.sems.masymos.diff.DiffJob.run(DiffJob.java:89)
	at de.unirostock.sems.masymos.diff.DiffExecutor.execute(DiffExecutor.java:101)
	at de.unirostock.sems.masymos.diff.DiffExecutor.main(DiffExecutor.java:186)

Change History (1)

comment:1 Changed 20 months ago by martinP

  • Resolution set to invalid
  • Status changed from new to closed

issue was not caused by BiVeS directly.

Note: See TracTickets for help on using tickets.
authorship