Opened 3 years ago

Closed 3 years ago

#20 closed task (fixed)

computation of attribute distances incorrect

Reported by: martin Owned by: martin
Priority: critical Milestone:
Component: code Version:
Keywords: Cc: martin

Description

the distance seems to be wrong, the computation has some problems with equality?

Change History (3)

comment:1 Changed 3 years ago by martin

might be related to the move to jdom? changeset:5af1f1e

comment:2 Changed 3 years ago by martin

indeed caused by changeset:5af1f1e
in source:src/main/java/de/unirostock/sems/xmlutils/ds/DocumentNode.java@5af1f1e#L636 we compare attribute objects, not their values... -> never equal -> distance always 1 as soon as there are attributes...

comment:3 Changed 3 years ago by Martin Scharm <martin@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 5caa198d47f48d1d836c2d8c930a89f12c5efeea:

patched comparison of attributes [fixes #20]

before changeset:5af1f1e attributes map was a simple key-value map
so comparison of values was fine. but now the values are attribute
objects -> comparision of these objects is not what we intended

Note: See TracTickets for help on using tickets.
authorship